The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Apache 2.3.13-beta  (Read 3422 times)

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Apache 2.3.13-beta
« on: July 04, 2011, 09:23:15 AM »

Well, the problem on XP has been fixed. Whether or not this version becomes an official release is not for me to guess at. I think it will, but there are problems with building mod_ldap on most platforms and that may just kill it. I would imagine as soon as those are hammered out, a 2.3.14 will be right behind it.

I am tempted to release 2.3.13, Steffen has over at Apache Lounge so the cat is out of the bag official or not [1]. This is his first release of 2.3.x unlike us who have been doing it for some time now.

If we do, we will have mod_ldap from sources 41 hours before the tag as they call it, it builds for me easily, there was a major change at hour 40 that really broke it.

[1] The ASF does not like it when folks make available versions that were not officially released. This is my only hesitation and is why up till now we never have. We could have them days ahead and ones that get voted down, but to be on the safe side we don't do either of these. There is a fine line here and these being beta makes it even grayer.

Edit: my bad speeling
« Last Edit: July 04, 2011, 10:02:22 AM by Gregg »
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 583
Re: Apache 2.3.13-beta
« Reply #1 on: July 05, 2011, 05:54:40 PM »

As I read in one of the last mails 2.3.13 is history.  http://www.gossamer-threads.com/lists/apache/dev/400468
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.13-beta
« Reply #2 on: July 05, 2011, 06:07:03 PM »

Yep, I Just saw in myself.
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
PHP now works with Apache 2.3
« Reply #3 on: July 10, 2011, 07:51:30 AM »

With a little help from the forums over at ApacheLounge, I got PHP loaded as a module.  No longer need to load fcgid module instead.  Seems the trunk build for PHP 5.4/5.5 dev now works with Apache 2.3.13.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.13-beta
« Reply #4 on: July 10, 2011, 11:23:33 PM »

Yes it should  since it was specifically built for that Apache bersion, it will not work with 2.3.14 since the module magic number has changed, but hopefully when 2.3.14 comes around, php will have a new snapshot built against it.

Why do we not have 2.3.13 up you may ask, the answer is it was not officially released. I do not think they care as much about that on the beta, but I do not want to find out the hard way. It was a release candidate, and I think Steffen has mentioned that, which is all we would have to do really, but I'd rather wait, things are better now, mod_ldap, mod_authnz_ldap build now too, and should work.

There is some back and forth going on at the ASF about the moving apr_ldap into HTTPd itself, till that is cleared up, I think we will just have to wait.

There is a problem with "AcceptFilter http/s none", hopefully that will get fixed soon as well.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13