The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1] 2 3   Go Down

Author Topic: Apache 2.3.12-beta Released  (Read 21253 times)

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Apache 2.3.12-beta Released
« on: June 02, 2011, 04:31:00 AM »

The Apache Haus has released our distribution of Version 2.3.12-beta of the Apache HTTP Server. Built with APR 1.4.5, APR-Util 1.3.12, OpenSSL 1.0.0d.

Apache 2.3.12-beta is simply the next in a series of beta versions.

Binaries are available on our Downloads Page.
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Apache 2.3.12-beta Released
« Reply #1 on: June 02, 2011, 12:16:00 PM »

Thank you Gregg.  Grabbed it over the weekend.

 - S
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.12-beta Released
« Reply #2 on: June 03, 2011, 05:59:21 AM »

Yeah, the EU mirror was down when I was uploading, was waiting for it before announcing. That reminds me, need to get it on that mirror still.
Logged

mbwebsolutions

  • Guest
Re: Apache 2.3.12-beta Released
« Reply #3 on: June 19, 2011, 12:43:37 PM »

thanks for this
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Apache 2.3.12-beta Released
« Reply #4 on: June 28, 2011, 02:47:30 PM »

Is there a version of PHP that works with the 2.3.12 build?

Thanks

 - Scott
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 583
Re: Apache 2.3.12-beta Released
« Reply #5 on: June 28, 2011, 10:46:32 PM »

Is there a version of PHP that works with the 2.3.12 build?

Thanks

 - Scott

Any with fcgid. In early 2.3.x I wasn't able to compile mod_php
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Apache 2.3.12-beta Released
« Reply #6 on: June 29, 2011, 12:20:23 AM »

Mario:

I got Mod_fcgid configured and loaded.  Just not having any luck with PHP.  Tried 5.3.6 and 5.3.7 RC1 with my install of Apache 2.3.12.  No luck.  Just does not work.  Any tips and/or tricks to get it to work would be greatly appreciated.

 - Scott
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Apache 2.3 and PHP
« Reply #7 on: July 01, 2011, 02:00:18 AM »

Anyone got it to work?  I have it installed and configured correctly but get errors starting.  Perhaps PHP 5.3.x and 5.4 Alpha are only for Apache 2.2?
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.12-beta Released
« Reply #8 on: July 01, 2011, 05:20:25 AM »

Actually I was playing with this today

gotta get on my laptop to show what I was seeing in my error log.

ok, on the lappy and here is what I am seeing with 5.3.6

[Thu Jun 30 18:13:39.829497 2011] [:info] [pid 4368:tid 944] mod_fcgid: server localhost:c:/php53ts/php-cgi.exe(3008) started
[Thu Jun 30 18:13:46.901497 2011] [:warn] [pid 4368:tid 1536] (OS 109)The pipe has been ended.  : [client ::1:49243] mod_fcgid: get overlap result error, referer: http://localhost/
[Thu Jun 30 18:13:46.901497 2011] [core:error] [pid 4368:tid 1536] [client ::1:49243] Premature end of script headers: phpinfo.php, referer: http://localhost/
[Thu Jun 30 18:13:51.012497 2011] [:info] [pid 4368:tid 944] mod_fcgid: process c:/php53ts/php-cgi.exe(3008) exit(communication error), return code 255

I have no problems with 5.2.x

Personally, I hate php ... I wish the world had not jumped on this beast like it did back in ~'98 ... it has been nothing but a major problem to the internet as a whole since.

Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Apache 2.3.12-beta Released
« Reply #9 on: July 01, 2011, 04:47:40 PM »

I have not tried PHP 5.2 flavors.  When I run Apache 2.2.19, I can run PHP 5.3.x and 5.4 Alpha builds.  The minute I go to Apache 2.3.12, POOF, PHP ceases to work (basically stating a module in PHP5xxx.dlll cannot be located.

 - S
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.12-beta Released
« Reply #10 on: July 02, 2011, 02:58:54 AM »

well yeah, you cannot load php5apache2_2 in APache 2.3, which is why we need fcgid. The problem is IMO fcgid doesn't like PHP5.3 or the other way around.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.12-beta Released
« Reply #11 on: July 02, 2011, 03:01:21 AM »

back somewhat on topic to this thread, Apache 2.3.13 test source was released a couple days ago. It will not run on XP (and I assume Server 2003), it does run on my x86 Vista without problems other than some known ones still needing repair.
Logged

Sob

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 72
Re: Apache 2.3.12-beta Released
« Reply #12 on: July 02, 2011, 05:58:43 AM »

ok, on the lappy and here is what I am seeing with 5.3.6
...

I have no problem with your httpd 2.3.12 x86 + fcgid + official php 5.3.6 nts. Not tested much, but it definitely does not die on phpinfo(). But I'm sure that I remember messages like "get overlap result error" and "Premature end of script headers", I had "lots of fun" with them at the beginning when I was trying to become friend with mod_fcgid. If only I remembered what was the solution...

Quote
Personally, I hate php ...

Oh come on, php is lovely! ;) Personally I've gone as far as using it not only for web, but also as my primary scripting language for various common tasks (all kinds of file processing and such). What I like most is the simplicity. By the time I'd barely figure out how to do the task in any other scripting or non-scripting language, I'm already finished when using php.

What I don't like is mod_fcgid. I tried hard, but that thing clearly doesn't like me, so now it's mutual. It's mostly its fcgi child process management and request queuing that we can't agree on. I hope that different approach using mod_proxy_fcgi will be the right solution for me, but I didn't have time to play with it yet.
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Apache 2.3.12-beta Released
« Reply #13 on: July 03, 2011, 12:38:08 AM »

Definitely a no go for running PHP 5.3 or 5.4 with Apache 2.3.12.  I have just decided to revert back to 2.2.219 and PHP 5.3 and 5.4 work just fine.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 844
Re: Apache 2.3.12-beta Released
« Reply #14 on: July 03, 2011, 03:39:07 AM »

Logged
Pages: [1] 2 3   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13