The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Windows 7 Test  (Read 9369 times)

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Windows 7 Test
« on: February 03, 2009, 11:50:09 AM »

Windows 7 built 7000 no updates made (in VMware Workstation 6.5)
Apache 2.2.11 from apachehaus.com
PHP 5.2.8 from php.net

Runs very smooth. No need to install the C++ runtime.

Changes I made was to change the ext path in php.ini and added PHP as module to httpd.conf

Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 833
Re: Windows 7 Test
« Reply #1 on: February 04, 2009, 08:47:07 AM »

We're you able to install as service?
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: Windows 7 Test
« Reply #2 on: February 04, 2009, 01:34:06 PM »

At first I got

Quote
C:\Apache2\bin>httpd -k install
Installing the Apache2.2 service
(OS 5)Zugriff verweigert  : Failed to open the WinNT service manager

(Zugriff verweigert german for Access denied)
Than I ran cmd as Administrator

Quote
C:\Apache2\bin>httpd -k install
Installing the Apache2.2 service
The Apache2.2 service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.

C:\Apache2\bin>httpd -k start

C:\Apache2\bin>

restarted Windows --> service is running can reach it over the network

Uninstall test run as Administrator

Quote
C:\Apache2\bin>httpd -k stop
The Apache2.2 service is stopping.
The Apache2.2 service has stopped.

C:\Apache2\bin>httpd -k uninstall
Removing the Apache2.2 service
The Apache2.2 service has been removed successfully.

C:\Apache2\bin>
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 833
Re: Windows 7 Test
« Reply #3 on: February 04, 2009, 03:50:42 PM »

I got same.

Not sure how to run command as admin but I did change properties on the httpd.exe file to run as admin and that worked. I then undid the admin property change and all works well. Just needed admin to get the service installed.

Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: Windows 7 Test
« Reply #4 on: February 04, 2009, 07:25:04 PM »

To run a shell as Administrator: Create a shortcut to cmd. And than rightclick  ;)
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: Windows 7 Test
« Reply #5 on: February 05, 2009, 11:12:46 PM »

Today I tested PHP in VS6 and VS9 build, both running fine.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 833
Re: Windows 7 Test
« Reply #6 on: March 06, 2009, 11:30:32 PM »

Unfortunately, not everything is fine.
I cannot build anything on W7
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: Windows 7 Test
« Reply #7 on: March 09, 2009, 09:41:34 AM »

Which SDK did you try? I'm not a man for compiling apache, but what error do you get?
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 833
Re: Windows 7 Test
« Reply #8 on: March 10, 2009, 08:38:14 PM »

Shit .. I need to set up some notifies.

No special SDK, just one incliuded with VC9.

The problem is when the compiler links the manafest file, that errors stating the object is not a valid "Windows Image"

Chances are compiling without manafest, and then just adding manafest files in the folders and I am sure all works fine, but that is not the way one wants to go.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13