Forum Topics > Apache 64 bit

Installing httpd-2.2.17-ssl-ipv6-x64

(1/1)

kjo:
I have been running win32 ASF apache 2.2.16 on WXP and all was well.
I upgraded to W7 and installed ASF 2.2.17 which worked. But I became confused
with the availability of w32 & w64 versions of PHP & MySQL and their interoperability.

So I uninstalled ASF 2.2.17 apache and installed AH httpd-2.2.17-ssl-ipv6-x64
with the intent of installing all 64b apache, PHP, MySQL.
(installed MS VC++ Redist also)
It works... But... How do I know that I am running 64b binaries and not 32b?
If I look at the httpd service it is reporting :

Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/1.0.0a

What should I conclude?

Gregg:
That I forgot to modify this line in os.h to say "Win64".

#define PLATFORM "Win32"


Best way to know, for sure, is to run this at a command line

httpd -V

look at the Architecture, if it's 64 bit, it will say it.

Navigation

[0] Message Index

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 
Go to full version