The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Apache 2.4.x mod_proxy_balancer debugging  (Read 137 times)

maxboyer

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Apache 2.4.x mod_proxy_balancer debugging
« on: September 03, 2020, 08:51:45 PM »

Hello from Canada!

I'm looking for some assistance. We're running Apache 2.4.46 (httpd-2.4.46-o111g-x64-vc15) on Windows Server 2012R2 as a reverse proxy load balancer.

Sometimes, the balancer workers report a busyness count greater than 0 (usually 1) on the balancer-manager status page, even though not seemingly serving any request. As a result, the requests are unevenly distributed between the 2 workers.

Restarting Apache clears the count, and it also clears itself after a while. What could cause this? KeepAlive?

I tried to debug the process, but the instructions for Windows seems to be outdated: http://httpd.apache.org/dev/debugging.html#backtrace-win
I can't find the *-symbols.zip download.

Is there instructions to build and debug Apache on Windows? What could I do to troubleshoot this further?

Thank you,
Max

Our environment:
    - OS: Windows Server 2012 R2 (x64)
    - Server Version: Apache/2.4.46 (Win64) OpenSSL/1.1.1g mod_h264_streaming/2.2.7
    - Server MPM: WinNT
    - Server Built: Aug 1 2020 13:21:32
    - Distributed by: The Apache Haus
    - Compiled with: Visual Studio 2017

Our configuration:
    - Single process (winnt mpm)
    - ThreadsPerChild 15000
    - Virtual host with proxy_balancer (HTTP/1.1 TLS 1.2)
    - 2 balancer workers (https to the 2 application servers)
        - lbmethod=bybusyness
        - stickysession=JSESSIONID
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 605
Re: Apache 2.4.x mod_proxy_balancer debugging
« Reply #1 on: September 04, 2020, 08:23:15 AM »

The KeepAlive is set by default between Apache and the backend server, since it uses HTTP/1.1

You can disable KeepAlive with

Code: [Select]
SetEnv proxy-nokeepalive 1
e.g.
Code: [Select]
<Location "/">
  ProxyPass "http:/appserver:8080/"
  SetEnv force-proxy-request-1.0 1
  SetEnv proxy-nokeepalive 1
</Location>
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 605
Re: Apache 2.4.x mod_proxy_balancer debugging
« Reply #2 on: September 04, 2020, 08:28:40 AM »

For debuging you can adjust the log level

Code: [Select]
LogLevel warn proxy:debug

or

proxy:trace5

Be aware that both settings will flood your log files a lot!
Logged

maxboyer

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: Apache 2.4.x mod_proxy_balancer debugging
« Reply #3 on: September 09, 2020, 02:50:39 AM »

Do you believe the KeepAlive would keep the worker busy?

Yeah, I'll test the logging on our test server.

Max
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 605
Re: Apache 2.4.x mod_proxy_balancer debugging
« Reply #4 on: September 09, 2020, 08:36:16 AM »

Do you believe the KeepAlive would keep the worker busy?

Hi Max,
that can be an option why it is that way.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13