The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: 2.3.9  (Read 6415 times)

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
2.3.9
« on: November 21, 2010, 07:59:05 PM »

No need to hold breath waiting for it. It's not coming this week unless someone fixes it.

Currently trunk is broke on Windows. Stefan's switch from ap_expr to the one from mod_ssl is not in the Win build system, so it doesn't compile. I had looked over the unix changes and tried to do same but I'm getting plenty of errors throughout libhttpd.

Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 586
Re: 2.3.9
« Reply #1 on: November 21, 2010, 09:48:40 PM »

The changed are documented on http://httpd.apache.org/docs/trunk/de/developer/new_api_2_4.html
Also the expression parser has been changed read in bug 50255
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 586
Re: 2.3.9
« Reply #2 on: November 22, 2010, 05:57:17 PM »

There were some changes, now it looks better, but libhttpd still does not build

Quote
libhttpd - 4 error(s), 5 warning(s)
========== Build: 5 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: 2.3.9
« Reply #3 on: November 22, 2010, 06:34:57 PM »

I saw that, one specifically was in an area fataling for me.
I just ran svn update and am going to hack at it again, see if I cannot figure it out. If not, since Jim just said T&R tomorrow, I'm going to -1 T&R till Windows build is fixed.

Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 586
Re: 2.3.9
« Reply #4 on: November 22, 2010, 08:31:54 PM »

You are right. A broken build is not a good start for a release.

LOL put a bug in bugzilla that windows build is broken  :D  ;D
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: 2.3.9
« Reply #5 on: November 23, 2010, 03:15:36 AM »

I went straight to the dev list with it, if they're thinking of T&Ring tomorrow, one must squeak loudly!
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: 2.3.9
« Reply #6 on: November 23, 2010, 05:11:42 PM »

It's up, it ain't gonna build and even when it does it's gonna get ugly.

Just swaping out the files in libhttpd.dsp is not enough. The same build event in mod_ssl needs to be run against the .y & .l files. I cannot figure how  they got the Lexical target's event to fire during a release/debug target build.

That can be worked around and in a way so can this.

There is a requirement for Flex 2.5.35. Well, if you start digging around for this version on Windows, you wont find much. I was able to find a MinGW & a cygwin version.
MinGW: http://sourceforge.net/projects/mingw/files/
Cygwin: http://www.postgresql.org/ftp/misc/winflex/

If I gotta install MinGW or Cygwin, they may as well just scrap Visual Studio and go to a MinGW/GCC build for Windows, which I've seen mention of being ugly.

Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 586
Re: 2.3.9
« Reply #7 on: November 23, 2010, 06:05:10 PM »

I prefer http://gnuwin32.sourceforge.net/

I don't the depencies to the cygwin files when then files are build with gcc.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: 2.3.9
« Reply #8 on: November 23, 2010, 06:22:22 PM »

Yes Mario,

But look at the version of Flex there ...
http://gnuwin32.sourceforge.net/packages/flex.htm

2.5.4a which was released for Unix June 27, 1997.

C:\buildprep\httpd-2.3.8>flex -Putil_expr_yy -s -B .\server\util_expr_scan.l
".\server\util_expr_scan.l", line 32: unrecognized %option: reentrant
".\server\util_expr_scan.l", line 33: unrecognized %option: bison-bridge
« Last Edit: November 23, 2010, 06:54:56 PM by Gregg »
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 586
Re: 2.3.9
« Reply #9 on: November 23, 2010, 08:25:36 PM »

:-/ I see. That's a real pittty.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: 2.3.9
« Reply #10 on: November 23, 2010, 11:54:03 PM »

You know, Jim pulled 2.3.7 from vote before I even got a copy of it cause it would not build on Solaris or OSX. Interestingly, he knew there were problems in Win cause of my mail so I like how he worded this one

"Pre-test tarballs of httpd-2.3.9-alpha..."

Pre-test ... that's funny to this nerd.
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 586
Re: 2.3.9
« Reply #11 on: November 29, 2010, 05:14:25 PM »

I read the dev list mails... seams 2.3.9 is dead on arrival. I think 2.3.10 will do better  ;)
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: 2.3.9
« Reply #12 on: November 29, 2010, 11:41:31 PM »

I'm sure it will. Now that Bill's back from holiday he'll look it over.

The warning count is getting quite deafening. 91 warnings off an svn pull today.
Guenter has the list of them, he's stomped out one in mod_ssl and looks like the other three are about to be stomped out as well.

The biggest offenders are apr_dbd_odbc and htcacheclean.

htcacheclean issues 21 warnings while apr_dbd_odbc issues 17, but it is built twice so 34
Just these two are 55, and they're minor stuff that MSVC considers sloppy I guess, not providing type conversions in-line.

Other than that, 2.3.10 is looking good to go.

Edit: htcacheclean: 0 warnings as of , well, bill just -1 the change
« Last Edit: December 01, 2010, 04:58:15 AM by Gregg »
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13