The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1] 2   Go Down

Author Topic: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above  (Read 1302 times)

long76

  • Newbie
  • *
  • Offline Offline
  • Posts: 10
Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« on: October 22, 2017, 01:57:48 PM »

how include libressl to Apache server? good would be returned like Experimental or without ;D, Apache with Libressl.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #1 on: October 24, 2017, 11:13:18 PM »

Apache broke compiling with LibreSSL when it became compatible with OpenSSL 1.1.0. It's been supposedly remedied but I haven't had time to check.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #2 on: November 04, 2017, 05:52:29 PM »

I had the time yesterday with the site being down all day to give this a go.

Good News: It worked and I have Apache 2.4.29 with LibreSSL 2.6.2 both x86 & x64.
Bad News: I cannot find my package creating script at the moment so I have to get out my old laptop and dig through it to get it back.

Once I find it I'll package these up and make them available for download and announce. I hope I do not have to recreate my packaging script but if I do, it may take a couple days to get these up.
Logged

long76

  • Newbie
  • *
  • Offline Offline
  • Posts: 10
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #3 on: November 05, 2017, 09:39:05 AM »

Thanks! ;)LibreSSL 2.6.2 it development release, it safe for use?)
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #4 on: November 05, 2017, 06:51:59 PM »

Ah, forgot to check that. Yes it is the development branch.

I have a tool that watches http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/ for changes, unfortunately that will not tell me if it's a dev branch. I guess I'll have to do LibreSSL differently.

I can do builds with 2.5.5 in a couple days.
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Apache 2.4.29 w/LibreSSL 2.62 - not working for me
« Reply #5 on: November 06, 2017, 05:16:24 PM »

Is anyone else getting this message "C:/Apache/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: The specified module could not be found." when they install and attempt to run Apache 2.4.29 w/LibreSSL 2.6.2?

I have tried it on 2 different machines with no luck  :'(
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #6 on: November 08, 2017, 06:13:46 PM »

Yeah, I have on my server. It runs on both my laptop and my desktop but not in the server.
With LibreSSL 2.5.5 it works fine on the server, so I dunno, must be a problem w/ 2.6.2.

Anyhow, I'll put up the 2.5.5 now and remove the 2.6.2.
Logged

long76

  • Newbie
  • *
  • Offline Offline
  • Posts: 10
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #7 on: November 10, 2017, 05:51:32 AM »

LibreSSL make new release 2.6.3. Maybe there was fixed bugs 2.6.2 with loading mod_ssl
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #8 on: November 15, 2017, 09:44:08 AM »

2.6.3 is listed as stable now so we will see.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #9 on: December 07, 2017, 09:46:26 PM »

Sorry it has taken me so long to get to this. Yes, 2.6.3 builds and they are on our download page.
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #10 on: December 07, 2017, 10:03:15 PM »

Awesome job
Logged

long76

  • Newbie
  • *
  • Offline Offline
  • Posts: 10
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #11 on: December 09, 2017, 01:01:04 PM »

yay) thanks)
Logged

long76

  • Newbie
  • *
  • Offline Offline
  • Posts: 10
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #12 on: December 09, 2017, 02:23:56 PM »

Invalid command 'SSLOpenSSLConfCmd'... command was delete or rename?
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #13 on: December 10, 2017, 12:20:43 AM »

Well this is an Apache Directive that notes OpenSSL 1.0.2 and higher. So with that in mind;

If the directive works on 2.4.29/Libressl 2.5.5, chances are whatever part of LRE's API was removed by LRE that supports this Apache directive. This would not be a surprise since there is a slimming down of the library of "unneeded code" so they deem almost every release.

Or

If the directive doesn't work on 2.4.29/Libressl 2.5.5, it's probably because LRE was forked from OpenSSL 1.0.1 and what of OpenSSL 1.0.2 is needed for the directive has never been added to LRE.
Logged

long76

  • Newbie
  • *
  • Offline Offline
  • Posts: 10
Re: Apache 2.4.28 VC14 x64 with LibreSSL 2.5.5 and above
« Reply #14 on: December 14, 2017, 02:36:18 PM »

thanks for answer. i asked LRE developers(https://github.com/libressl-portable/portable/issues/367), as i understand mod_ssl should have options for curves and ECDHParametres.
Logged
Pages: [1] 2   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13