The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Apache responds with HTTP/1.1 200 OK but does not include the body of text.  (Read 1138 times)

[email protected]

  • Newbie
  • *
  • Offline Offline
  • Posts: 5

Apache responds with a HTTP/1.1 200 OK but does not include the body of text given to it?
Is there CGI forum that I should be posting question to? Thanks Roger
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837

What is this your giving it? Perl, PHP, Python, Ruby or VBS?
Logged

[email protected]

  • Newbie
  • *
  • Offline Offline
  • Posts: 5

My cgi programs are in written in Microsoft C#,  I sent through the gateway:

Content-Type: application/soap+xml; charset=utf-8
Content-Length: 47
url=http://www.mastercom.com/uploadsuccess.html

and get
The "getPostResponse()" method calls the "readHeaders()" method.
<readHeaders()>
<R: Date: Thu, 26 Jan 2017 03:44:40 GMT>
<R: Server: Apache/2.4.23 (Win64) OpenSSL/1.0.2j>
<R: Keep-Alive: timeout=5, max=100>
<R: Connection: Keep-Alive>
<R: Transfer-Encoding: chunked>
<R: Content-Type: application/soap+xml; charset=utf-8>
<R: >

Why am I getting "Transfer-Encoding: chunked" ?   Since I sent Content-Length: 47,  I want Content-Length: 47>

Is there anyway to escape from the gateway intelligence and have it take what it is given and pass it through to the socket.
I only want to do that when the CGI is not doing what I want.
I do own HTTP programming and it is irritating trying to second guess why the CGI is doing what it is doing.
Thanks
Roger
 
 
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13