The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Sorry Guest, you are banned from posting and sending personal messages on this forum.
Error: S4296
This ban is not set to expire.
Pages: [1]   Go Down

Author Topic: Apache won't start Windows 7  (Read 3290 times)

johnrdorazio

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
Apache won't start Windows 7
« on: October 15, 2015, 05:41:47 PM »

I can't get Apache to fire up on my computer. I have Windows 7, and I have Visual Studio 2013. I have installed runtimes for VC9and VC11 just to be sure. But anytime I try to launch httpd.exe it crashes.

The system events are showing me this error:

Nome registro: Application
Origine:       Application Error
Data:          15/10/2015 17:17:11
ID evento:     1000
Categoria attività:(100)
Livello:       Errore
Parole chiave: Classico
Utente:        N/D
Computer:      donJohn-PCFisso
Descrizione:
Nome dell'applicazione che ha generato l'errore: httpd.exe, versione: 2.4.16.0, timestamp: 0x55a22a64
Nome del modulo che ha generato l'errore: libapr-1.dll, versione: 1.5.2.0, timestamp: 0x55a22bbb
Codice eccezione: 0xc0000005
Offset errore 0x00011fcb
ID processo che ha generato l'errore: 0x1744
Ora di avvio dell'applicazione che ha generato l'errore: 0x01d1075c9045f9a7
Percorso dell'applicazione che ha generato l'errore: C:\xampp\apache\bin\httpd.exe
Percorso del modulo che ha generato l'errore: C:\xampp\apache\bin\libapr-1.dll
ID segnalazione: ce3b8986-734f-11e5-9a9c-00508d6827ba
XML evento:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-10-15T15:17:11.000000000Z" />
    <EventRecordID>31682</EventRecordID>
    <Channel>Application</Channel>
    <Computer>donJohn-PCFisso</Computer>
    <Security />
  </System>
  <EventData>
    <Data>httpd.exe</Data>
    <Data>2.4.16.0</Data>
    <Data>55a22a64</Data>
    <Data>libapr-1.dll</Data>
    <Data>1.5.2.0</Data>
    <Data>55a22bbb</Data>
    <Data>c0000005</Data>
    <Data>00011fcb</Data>
    <Data>1744</Data>
    <Data>01d1075c9045f9a7</Data>
    <Data>C:\xampp\apache\bin\httpd.exe</Data>
    <Data>C:\xampp\apache\bin\libapr-1.dll</Data>
    <Data>ce3b8986-734f-11e5-9a9c-00508d6827ba</Data>
  </EventData>
</Event>


Looks like it has something to do with libapr-1.dll?

Also if I try installing XAMPP I get similar crashes:

Nome registro: Application
Origine:       Application Error
Data:          15/10/2015 17:18:00
ID evento:     1000
Categoria attività:(100)
Livello:       Errore
Parole chiave: Classico
Utente:        N/D
Computer:      donJohn-PCFisso
Descrizione:
Nome dell'applicazione che ha generato l'errore: php.exe, versione: 5.6.12.0, timestamp: 0x55c3b0d8
Nome del modulo che ha generato l'errore: php5ts.dll, versione: 5.6.12.0, timestamp: 0x55c3b699
Codice eccezione: 0xc000001d
Offset errore 0x000470b3
ID processo che ha generato l'errore: 0xd0
Ora di avvio dell'applicazione che ha generato l'errore: 0x01d1075cad794aaf
Percorso dell'applicazione che ha generato l'errore: C:\xampp\php\php.exe
Percorso del modulo che ha generato l'errore: C:\xampp\php\php5ts.dll
ID segnalazione: eb7352f6-734f-11e5-9a9c-00508d6827ba
XML evento:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-10-15T15:18:00.000000000Z" />
    <EventRecordID>31684</EventRecordID>
    <Channel>Application</Channel>
    <Computer>donJohn-PCFisso</Computer>
    <Security />
  </System>
  <EventData>
    <Data>php.exe</Data>
    <Data>5.6.12.0</Data>
    <Data>55c3b0d8</Data>
    <Data>php5ts.dll</Data>
    <Data>5.6.12.0</Data>
    <Data>55c3b699</Data>
    <Data>c000001d</Data>
    <Data>000470b3</Data>
    <Data>d0</Data>
    <Data>01d1075cad794aaf</Data>
    <Data>C:\xampp\php\php.exe</Data>
    <Data>C:\xampp\php\php5ts.dll</Data>
    <Data>eb7352f6-734f-11e5-9a9c-00508d6827ba</Data>
  </EventData>
</Event>


Nome registro: Application
Origine:       Application Error
Data:          15/10/2015 17:18:00
ID evento:     1005
Categoria attività:(100)
Livello:       Errore
Parole chiave: Classico
Utente:        N/D
Computer:      donJohn-PCFisso
Descrizione:
Impossibile accedere al file  per uno dei motivi seguenti:  Si è verificato un problema relativo alla connessione di rete, al disco in cui è archiviato il file o ai driver di archiviazione installati nel computer oppure il disco è assente. Il programma CLI è stato chiuso a causa dell'errore.

Programma: CLI
File:

Il valore dell'errore è indicato nella sezione Dati aggiuntivi.
Azione utente
1. Aprire nuovamente il file. Potrebbe trattarsi di un problema temporaneo che si risolverà automaticamente rieseguendo il programma.
2. Se il file risulta comunque non accessibile e:
   - Si trova in rete, è necessario che l'amministratore della rete verifichi la presenza di eventuali problemi di rete e che sia possibile contattare il server.
   - Si trova in un disco rimovibile, ad esempio un disco floppy o un CD, verificare che il disco sia inserito correttamente nel computer.
3. Controllare e ripristinare il file system eseguendo CHKDSK. Per eseguire CHKDSK, fare clic sul pulsante Start, scegliere Esegui, digitare CMD, quindi scegliere OK. Al prompt dei comandi, digitare CHKDSK /F, quindi premere INVIO.
4. Se il problema persiste, ripristinare il file da una copia di backup.
5. Determinare se è possibile aprire altri file nello stesso disco. Se non è possibile, il disco potrebbe essere danneggiato. Se si tratta di un disco rigido, contattare l'amministratore o il fornitore dell'hardware del computer per ottenere assistenza.

Dati aggiuntivi
Valore errore: 00000000
Tipo disco: 0
XML evento:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="49152">1005</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-10-15T15:18:00.000000000Z" />
    <EventRecordID>31685</EventRecordID>
    <Channel>Application</Channel>
    <Computer>donJohn-PCFisso</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>CLI</Data>
    <Data>00000000</Data>
    <Data>0</Data>
  </EventData>
</Event>


I have disabled IIS, I have tried using different listening ports, I have tried with elevated privileges... Nothing is working so far.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 849
Re: Apache won't start Windows 7
« Reply #1 on: October 16, 2015, 03:54:40 AM »

Those do not tell us much. Better is the error.log file, but before that, try and start it from the command like with
httpd -i debug

Sorry for the delay
Logged

itspeaks

  • Newbie
  • *
  • Offline Offline
  • Posts: 9
Re: Apache won't start Windows 7
« Reply #2 on: October 19, 2015, 06:59:16 AM »

Look - don't quote me as my Italian is rubbish - You appear to be running Apache from an account that doesn't have privileges. any chance you can try running it "As administrator"?

Otherwise change the permissions of the folders mentioned in the error to allow USERS to modify.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13