The Apache Haus Forum

Forum Topics => Apache 2.4 => Topic started by: [email protected] on January 14, 2017, 05:48:06 AM

Title: Apache responds with HTTP/1.1 200 OK but does not include the body of text.
Post by: [email protected] on January 14, 2017, 05:48:06 AM
Apache responds with a HTTP/1.1 200 OK but does not include the body of text given to it?
Is there CGI forum that I should be posting question to? Thanks Roger
Title: Re: Apache responds with HTTP/1.1 200 OK but does not include the body of text.
Post by: Gregg on January 14, 2017, 07:36:08 PM
What is this your giving it? Perl, PHP, Python, Ruby or VBS?
Title: Re: Apache responds with HTTP/1.1 200 OK but does not include the body of text.
Post by: [email protected] on January 26, 2017, 05:13:01 AM
My cgi programs are in written in Microsoft C#,  I sent through the gateway:

Content-Type: application/soap+xml; charset=utf-8
Content-Length: 47
url=http://www.mastercom.com/uploadsuccess.html

and get
The "getPostResponse()" method calls the "readHeaders()" method.
<readHeaders()>
<R: Date: Thu, 26 Jan 2017 03:44:40 GMT>
<R: Server: Apache/2.4.23 (Win64) OpenSSL/1.0.2j>
<R: Keep-Alive: timeout=5, max=100>
<R: Connection: Keep-Alive>
<R: Transfer-Encoding: chunked>
<R: Content-Type: application/soap+xml; charset=utf-8>
<R: >

Why am I getting "Transfer-Encoding: chunked" ?   Since I sent Content-Length: 47,  I want Content-Length: 47>

Is there anyway to escape from the gateway intelligence and have it take what it is given and pass it through to the socket.
I only want to do that when the CGI is not doing what I want.
I do own HTTP programming and it is irritating trying to second guess why the CGI is doing what it is doing.
Thanks
Roger
 
 
Title: Re: Apache responds with HTTP/1.1 200 OK but does not include the body of text.
Post by: Gregg on January 26, 2017, 07:47:40 AM
http://serverfault.com/questions/59047/apache-sending-transfer-encoding-chunked