The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: 1 ... 6 7 [8] 9 10
 71 
 on: February 08, 2018, 03:18:40 PM 
Started by casinobet77 - Last post by casinobet77
I'm working on Windows 10 with WAMP 3.0.6 (Apache 2.4.23, PHP 5.6.25) and when I try to run composer update It displays the error with OpenSSL:

Loading composer repositories with package information
The "https://packagist.org/packages.json" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed
https://packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date
Updating dependencies (including require-dev)

I have already set openssl.cafile variable in c:\wamp\bin\php\php5.6.25\php.ini and confirmed that this php.ini file is used by CLI.
Output of php -r "var_dump(openssl_get_cert_locations());"

array(8) {
  ["default_cert_file"]=>
  string(25) "c:/usr/local/ssl/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(22) "c:/usr/local/ssl/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(24) "c:/usr/local/ssl/private"
  ["default_default_cert_area"]=>
  string(16) "c:/usr/local/ssl"
  ["ini_cafile"]=>
  string(29) "c:/wamp/openssl/cacert.pem"
  ["ini_capath"]=>
  string(16) "c:/wamp/openssl/"
}
I downloaded certificate file from http://curl.haxx.se/ca/cacert.pem and tried to place it to different locations:

c:/wamp/openssl/
c:/usr/local/ssl/certs
c:/usr/local/ssl/cert.pem


I'm working on Windows 10 with WAMP 3.0.6 (Apache 2.4.23, PHP 5.6.25) and when I try to run composer update It displays the error with OpenSSL:

Loading composer repositories with package information
The "https://packagist.org/packages.json" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed
https://packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date
Updating dependencies (including require-dev)
I have already set openssl.cafile variable in c:\wamp\bin\php\php5.6.25\php.ini and confirmed that this php.ini file is used by CLI.

Output of php -r "var_dump(openssl_get_cert_locations());"

array(8) {
  ["default_cert_file"]=>
  string(25) "c:/usr/local/ssl/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(22) "c:/usr/local/ssl/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(24) "c:/usr/local/ssl/private"
  ["default_default_cert_area"]=>
  string(16) "c:/usr/local/ssl"
  ["ini_cafile"]=>
  string(29) "c:/wamp/openssl/cacert.pem"
  ["ini_capath"]=>
  string(16) "c:/wamp/openssl/"
}
I downloaded certificate file from http://curl.haxx.se/ca/cacert.pem and tried to place it to different locations:

c:/wamp/openssl/ เล่นคาสิโนบนมือถือ
c:/usr/local/ssl/certs
c:/usr/local/ssl/cert.pem
I tried even reinstalling composer, using composer-setup.exe from getcomposer.org but it ends with the same error.

I searched stackoverflow and googled for hours but any of possible solutions have not worked. What am I doing wrong ?

 72 
 on: January 30, 2018, 03:23:52 PM 
Started by hyaa - Last post by mario
You can use any PHP Version as long as you use mod_fcgid ;)

 73 
 on: January 26, 2018, 01:54:27 PM 
Started by hyaa - Last post by long76
Hi,

I am using httpd-2.4.18-x64-vc11 and php-5.6.19-nts-Win32-VC11-x64 for a 64 bit windows. Upon adding a php handler it says "couldn't load php5apache2_4.dll : x1 is not a valid win32 application" .

Although, when i comment those handlers Apache starts perfectly fine. can some one help me out in identifying the correct dll file for the php Apache integration in my case?

php with version < 7.0 work only on x86 apache. if you want use php 5.6 you need apache x86 vc11 and php 5.6 vc11 TS(thread safe) for windows. if you need x64 u must upgrade apache for last x64 version and php to any 7.x version x64 TS(thread safe)

 74 
 on: January 20, 2018, 02:48:32 AM 
Started by hyaa - Last post by Gregg
PHP 7.0.x needs a VC14 OpenSSL 1.0.2 build of Apache to be able to load as a module.

 75 
 on: January 19, 2018, 10:23:19 PM 
Started by hyaa - Last post by aschmidt
Hello,
I just read this post. I am having the same difficulties trying to install PHP 7.0.27. I also tried using 5.3.6 and got the same error message. So just how are we supposed to 'downgrade' the ssl? How can we find out what version of SSL PHP uses?

I have spent many hours trying to find a rational solution.

 76 
 on: January 12, 2018, 10:41:05 PM 
Started by ppayne - Last post by Gregg
Confirmed. There was no hack of the member list.

This person spent 2 hours on this board using the email member feature to manually send out those Nigerian 419 scams (at least that's what I received). Talk about a time consuming way to do it.

This person has been banned, their entire netblock has been banned so there's an entire ISP in the Ivory Coast that cannot connect.

 77 
 on: January 11, 2018, 03:08:25 PM 
Started by saharsa - Last post by frDaniel
THANK YOU VERY MUCH!!!!!

It works! ;D

Just placed your dll's in Apache/bin directory.

 78 
 on: January 06, 2018, 12:24:31 PM 
Started by itspeaks - Last post by WERTYU
thank you ufabet [size]

 79 
 on: January 05, 2018, 09:27:58 PM 
Started by Gregg - Last post by Gregg
Well the download page has been warning everyone that support for VC9 was ending on 31-12-2017 for most of 2017 and today I finally removed the VC9 files from it. I really wanted to do this 2 years ago because my spare time became very limited but I felt I needed to give everyone using vc9 builds long enough to decide what they needed to do which I feel I did.

Some of that lost spare time is finally coming back but I want to do other things with it than support VC9 any longer.

So bye bye VC9.

 80 
 on: January 04, 2018, 11:45:39 PM 
Started by saharsa - Last post by Gregg
OK, I got it to load so that hurdle is behind us.

The problem that saharsa had getting it to work was a dependency I did not find when looking at the dependency tree (libiconv-2.dll).

See My Messages in the menu above for the URL to the file.

Pages: 1 ... 6 7 [8] 9 10