The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: 1 2 3 [4] 5 6 ... 10
 31 
 on: April 13, 2020, 10:12:20 PM 
Started by craptor - Last post by craptor
Hi,

Are the SHA1 Checksum links on the Downloads page not working at the moment or is it just me/my browser?

Thanks,
Ethan

 32 
 on: April 09, 2020, 10:21:22 AM 
Started by mdrmdr - Last post by mdrmdr
Now the developers are informed:
http://apache-http-server.18135.x6.nabble.com/mod-http2-crashes-libhttpd-dll-in-2-4-43-td5052261.html

 33 
 on: April 08, 2020, 10:48:20 PM 
Started by mdrmdr - Last post by mdrmdr
I think I found the cause.

It's mod_http2. Either when I disable http2 in httpd.conf or when I use the .41 module, everything works again.
So one of the changes from .41 to .43 must have caused the crash.

I reported this finding also in the Apache Lounge board linked above.

 34 
 on: April 08, 2020, 01:51:38 PM 
Started by mdrmdr - Last post by mdrmdr
I am already admin with enhanced user rights (set via gpedit.msc). To be sure I ran httpd.exe as "TrustedInstaller" using NirSoft's "AdvancedRun". Same result :-(
But, "Access Violation" usually has nothing to do with user rights. Usually this happens on a programming error when the programm tries to access the address 0 (zero pointer exception).

 35 
 on: April 08, 2020, 01:32:25 PM 
Started by mdrmdr - Last post by mario
The access violation.... did you try to run the apache service with a different user so far? I had the problem using shared memory and the default service user wasn't allowed to do so.

 36 
 on: April 08, 2020, 09:39:31 AM 
Started by mdrmdr - Last post by mdrmdr
Please note, I posted the below question in the forum of "www.apachelounge.com", but could not get a solution there. I hope it's ok to post the same question here.

Hi,

since quite a while I use Apache x64 2.4.41 for the staging of my website. It runs on latest Windows 10 (all updates) with PHP 7.4.4 and Perl 5.30.2. It's configured for TLS 1.3 only with "SSLProtocol -all TLSv1.3" and HTTP/2. The lastest Visual C++ Redistributable is installed.

Yesterday I updated to Apache x64 2.4.43. I copied the whole "conf" directory from .41 to .43 without any changes. Almost all of my site still works. But *all* https calls to Perl URLs now fail. Regardless of a direct URL or using PHP cURL. http works fine. PHP/https also works fine. Perl is configured as "ScriptInterpreterSource registry-strict" using .pl and .cgi settings in the registry. Calling Perl with PHP system or exec also works fine.

There are *no* error messages at all in the browser. Also *no* error messages when I instruct cURL to write a verbose logfile. Windows event log shows an app crash of httpd.exe (in detail libhttpd.dll). Exception is "0xc0000005" (access violation) at "Error offset: 0x00000000000266f9". "ScriptLog" does not even create a file.

Where do I start to look for errors? Why fails a fully working .41 environment in .43? If required, I'll upload (parts of) my config files.

Thanks for any help
mdrmdr

PS: For further reference, this is the link to the short thread in Apache Lounge

 37 
 on: April 04, 2020, 08:52:44 AM 
Started by Arun - Last post by Arun
Thank you Gregg for giving the SHA-1 Checksums for the builds.

-Arun

 38 
 on: April 04, 2020, 12:53:41 AM 
Started by rbol - Last post by Gregg
If serverone.crt & servertwo.crt are even in the ssl folder, I guess I need to revisit that part of my packager.

I was going to go with a six month certificate, generated at packaging time because I was seeing sites still using them years later, live online, and wanted that practice to end. Then a few things happened to delay me and now it's been too long I guess since they've expired. Oops.  :-[

Thanks for the heads up!

I have a lot things I need to revisit and I'll put this one on the top of the list. After all, no better time to revisit stuff than being on lock down. At least we don't have curfews and roadblocks yet but the way lock down is working I figure we will end up there soon enough.

 39 
 on: April 03, 2020, 11:49:35 PM 
Started by rbol - Last post by rbol
It appears there are 3 certificates in the SSL folder that expired on 4/3/2020

On Windows path - > Apache24\conf\ssl

Files - server.crt, serverone.crt, servertwo.crt

From what I can tell the files are referenced by the http-ssl.conf and http-ahssl.conf files
I had a server with the ahssl.conf file uncommented so was receiving some messages about the certificate. The module in my case should have been commented and not used.

Is there a plan to update those certificates in a new package?

 40 
 on: April 03, 2020, 07:27:39 PM 
Started by simcax - Last post by Gregg
Assuming the path used is correct and we are being shown a sanitized one:

I wonder if this problem is the same as with mod_ext_filter (both create an external process) in that it fails with APR 1.7.0 or if you should be using all double backslashes all the way through that ErrorLog string of yours since Windows doesn't understand forward slashes as a path separator. I have only used mod_log_rotate and never logrotate.exe but it seems to me I remember seeing an example that used \\ on windows decades ago. So try;

ErrorLog "|c:\\path\\to\\Apache\\Apache24\\bin\\rotatelogs.exe -l C:\\path\\to\\logs\\error.%Y-%m-%d-%H-%M-%S.log 86400"

Let me know if that works. If not I will compile httpd-2.4.43-o111f-x86-vc15 that instead uses APR 1.6.5 that you can test and if that works, I will go back to apr 1.6.5 till the problem with 1.7.0 gets fixed.







Pages: 1 2 3 [4] 5 6 ... 10