The Apache Haus Forum

Forum Topics => Third-party Modules => Topic started by: chromerep on July 07, 2013, 11:24:27 AM

Title: ZendOptimizerPlus for php5.2.X..
Post by: chromerep on July 07, 2013, 11:24:27 AM
I notice that an info there:https://github.com/zendtech/ZendOptimizerPlus (https://github.com/zendtech/ZendOptimizerPlus)
Is it possible to compile that for PHP 5.2.*, 5.3.*, 5.4.* to increase php-cgi.exe performance?:D
Title: Re: ZendOptimizerPlus for php5.2.X..
Post by: mario on July 08, 2013, 10:42:23 PM
It was been renamed to opcache

Betas:
 http://windows.php.net/downloads/pecl/snaps/opcache/

Releases:
 http://windows.php.net/downloads/pecl/releases/opcache/

But it goes only back to 5.3.x. 

I think there won't be a backport to 5.2.x also 5.2.x is EOL!
Title: Re: ZendOptimizerPlus for php5.2.X..
Post by: chromerep on July 09, 2013, 02:55:15 AM
Thanks.
But,I think it seems not good for php-cgi.exe performance. :D Am I guess right?
Title: Re: ZendOptimizerPlus for php5.2.X..
Post by: mario on July 09, 2013, 10:16:56 AM
Thanks.
But,I think it seems not good for php-cgi.exe performance. :D Am I guess right?

if you let the cgi process life long enough (fcgid) it is worth to have opcache. For plain cgi with only a single request it doesn't make sense.