The Apache Haus Forum

Forum Topics => Apache 2.4 => Topic started by: hyaa on March 09, 2016, 08:04:42 AM

Title: couldn't load PHP5apache2_4.dl
Post by: hyaa on March 09, 2016, 08:04:42 AM
Hi,

I am using httpd-2.4.18-x64-vc11 and php-5.6.19-nts-Win32-VC11-x64 for a 64 bit windows. Upon adding a php handler it says "couldn't load php5apache2_4.dll : x1 is not a valid win32 application" .

Although, when i comment those handlers Apache starts perfectly fine. can some one help me out in identifying the correct dll file for the php Apache integration in my case?

Title: Re: couldn't load PHP5apache2_4.dl
Post by: Gregg on March 09, 2016, 07:39:14 PM
Try using the OpenSSL 1.0.1s downgrade. The problem is (usually) that php uses OpenSSL 1.0.1 but Apache uses OpenSSL 1.0.2, they have to match and that is why we supply 1.0.1 downgrades.
Title: Re: couldn't load PHP5apache2_4.dl
Post by: aschmidt on January 19, 2018, 10:23:19 PM
Hello,
I just read this post. I am having the same difficulties trying to install PHP 7.0.27. I also tried using 5.3.6 and got the same error message. So just how are we supposed to 'downgrade' the ssl? How can we find out what version of SSL PHP uses?

I have spent many hours trying to find a rational solution.
Title: Re: couldn't load PHP5apache2_4.dl
Post by: Gregg on January 20, 2018, 02:48:32 AM
PHP 7.0.x needs a VC14 OpenSSL 1.0.2 build of Apache to be able to load as a module.
Title: Re: couldn't load PHP5apache2_4.dl
Post by: long76 on January 26, 2018, 01:54:27 PM
Hi,

I am using httpd-2.4.18-x64-vc11 and php-5.6.19-nts-Win32-VC11-x64 for a 64 bit windows. Upon adding a php handler it says "couldn't load php5apache2_4.dll : x1 is not a valid win32 application" .

Although, when i comment those handlers Apache starts perfectly fine. can some one help me out in identifying the correct dll file for the php Apache integration in my case?

php with version < 7.0 work only on x86 apache. if you want use php 5.6 you need apache x86 vc11 and php 5.6 vc11 TS(thread safe) for windows. if you need x64 u must upgrade apache for last x64 version and php to any 7.x version x64 TS(thread safe)
Title: Re: couldn't load PHP5apache2_4.dl
Post by: mario on January 30, 2018, 03:23:52 PM
You can use any PHP Version as long as you use mod_fcgid ;)