The Apache Haus Forum

Forum Topics => Apache 2.4 => Topic started by: prasanna.adkri on January 06, 2016, 11:46:55 AM

Title: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: prasanna.adkri on January 06, 2016, 11:46:55 AM
I'm using Apache2.4 and PHP 7.

When I added the following two lines in 'httpd.conf' of Apache, it stopped working.
Code: [Select]
LoadModule php7_module "D:/ProgramFiles/PHP/php7apache2_4.dll"
PHPIniDir "D:/ProgramFiles/PHP"

The error message is like this:
Code: [Select]
D:\ProgramFiles\ApacheHTTPServer\bin>httpd.exe
httpd.exe: Syntax error on line 180 of D:/ProgramFiles/ApacheHTTPServer/conf/httpd.conf: Cannot load  D:/ProgramFiles/PHP/php7apache2_4.dll into server: The specified module could not be found.

Anyone have any idea?
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: mario on January 07, 2016, 01:50:56 PM
Yepp,
PHP 7 is compiled VC 14 while we use VC11.

However use PHP over fcgid that is highly recommended
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: zrfisaac on February 19, 2016, 12:19:38 PM
I had the same problem. i resolved that puting the 'vcruntime140.dll' on my php directory that you can download on the following link:

http://pt.dll-files.com/vcruntime140.dll.html
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: Gregg on February 20, 2016, 06:28:21 PM
Hmm, That's good to know. I failed at that with Apache itself (just putting the vc14 runtime dll in the bin folder) but who knows, I should have tried with a different computer.
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: SanekWM on March 05, 2016, 09:16:48 AM
Gregg, Apache2 and modules how soon will be compiled VC 14?
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: Gregg on March 05, 2016, 06:29:42 PM
Hi,

Beginning with 2.4.19 I plan to start providing VC14 builds. Since there is movement at ASF to get 2.4.19 out the door, it should be here in the next week or two.
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: Quest on March 22, 2016, 10:53:30 AM
Hi,

Beginning with 2.4.19 I plan to start using https://skinnyexpress.com/phen375-review-and-results the phen375 stuff and providing VC14 builds. Since there is movement at ASF to get 2.4.19 out the door, it should be here in the next week or two.

Cool, is it done yet Gregg?
Title: Re: Apache2.4 and PHP7 (php7apache2_4.dll)
Post by: Gregg on March 22, 2016, 07:31:18 PM
It just so happens that 2.4.19 was tagged yesterday but will not see the light of day so it's going to be 2.4.20 ... just a bit longer.