The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: mod geoip  (Read 5916 times)

perindu

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
mod geoip
« on: August 26, 2009, 03:28:20 PM »

hi guys

first of all thanks for nice  tips and support for win32. Ive try mod geoip but seem it doesnt work with my apache 2.2.11 ive already install the file that needed and use depends program to find out which of file that will use but its not work. any idea?
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: mod geoip
« Reply #1 on: August 26, 2009, 05:22:03 PM »

Hi!
What error message do you get?

Did you install the Microsoft Visual C++ 2008 Redistributable Package? Cause our modules are compiled with VS9 and not VS6.
Logged

perindu

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
Re: mod geoip
« Reply #2 on: September 09, 2009, 03:22:18 PM »

hi thanks for reply sorry im bz

ive already install Microsoft Visual C++ 2008 Redistributable Package. ive also follow the instruction in your readme but apache is refused to start. Im using apache binary from apache website is that a problem? i can load modsecurity from apachelounge and i can use modgeoip from gknw website.

Ive try depends to find any module that needed but seem theres no problem at all.  any suggestion?
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: mod geoip
« Reply #3 on: September 09, 2009, 04:59:07 PM »

Anythinng in your error.log or in the windows event log?

I haven't tried mod_geoip with 2.2.11 but with 2.2.13 it works. You might grade up and try again? Is that possible?

A nice tools to find out if all needed dlls und stuff available is dependencywalker.com
Logged

perindu

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
Re: mod geoip
« Reply #4 on: September 11, 2009, 03:46:50 PM »

nope its just refused to start i will try the latest apache this weekends :) err ive already use that dependacywalker huhu i spell it  depends :) i'll try to check furthermore since modsecurity that compile from apachelouge work.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: mod geoip
« Reply #5 on: September 11, 2009, 06:05:22 PM »

After some testing it seems this module does not work with Apache.org (2.2.11 anyway) binaries. This is a somewhat known issue that some things do work (VC9 mod_antiloris does for example) and some simply do not, and it looks like mod_geoip simply does not.
« Last Edit: September 11, 2009, 06:07:13 PM by Gregg »
Logged

perindu

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
Re: mod geoip
« Reply #6 on: September 14, 2009, 10:22:26 AM »

ouch too bad i'll update my apache to latest : thanks

out of topic

i've already test mod_antiloris 0.4 its work with apache 2.2.11 :) i wonder if you can compile cronolog module :)
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 575
Re: mod geoip
« Reply #7 on: September 14, 2009, 02:18:22 PM »

Not on this page, but on apachelounge download page there is mod_log_rotate which works fine with access log. Error log is not supported yet.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13