The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Steps to Update Apache to 2.4.25 from 2.4.10  (Read 4547 times)

ganesh.esvk

  • Guest
Steps to Update Apache to 2.4.25 from 2.4.10
« on: January 05, 2017, 12:12:51 PM »

Dear All,

I am new to Apache, found Apache Haus web server in my new environment. And I am in the need to update the version to 2.4.25 as per policy.
Current version is 2.4.10, can anyone help me with the procedure to follow.

Thanks in advance.

Regards
VL.Ganesh
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Steps to Update Apache to 2.4.25 from 2.4.10
« Reply #1 on: January 06, 2017, 01:02:28 AM »

What version of Windows are you running? 32 or 64 bit?
What version of PHP are you running?

Logged

ganesh.esvk

  • Guest
Re: Steps to Update Apache to 2.4.25 from 2.4.10
« Reply #2 on: January 08, 2017, 07:55:41 AM »

Dear Gregg,

Thanks for your response.

We are using "Windows 2008 R2 -64 bit".
We are not using PHP, we have mapped a web application URL(deployed on JBOSS) in the Apache configuration file.

We need to update Apache without affecting the existing configuration.

Regards
VL.Ganesh
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Steps to Update Apache to 2.4.25 from 2.4.10
« Reply #3 on: January 08, 2017, 08:34:21 PM »

Use httpd -V from the command line and the compiler will be shown. For example:

C:\Apache24\bin>httpd -V
Server version: Apache/2.4.10 (Win64)
Server built:   Oct 19 2014 10:58:23
Distributed by: The Apache Haus
Compiled with:  Visual Studio 2012
Server's Module Magic Number: 20120211:36
Server loaded:  APR 1.5.1, APR-UTIL 1.5.3
Compiled using: APR 1.5.1, APR-UTIL 1.5.3
Architecture:   64-bit
Server MPM:     WinNT


1. Shutdown Apache.
1. Back up your current /bin and /modules folders.
2. Download 2.4.25 of the same compiler and architecture.
3. Replace all files in these 2 folders with the ones from 2.4.25 package.

4. Try starting Apache. It should work.
5. Optionally, you can replace the files in /include and /lib folders like you did above.

It's typically that easy to upgrade.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13