The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Apache 2.2.29 crashes when trying to upgrade to OpenSSL 1.0.2g  (Read 3297 times)

Zeev

  • Newbie
  • *
  • Offline Offline
  • Posts: 2

I have Apache 2.2.29 with OpenSSL 0.9.8 installed (on Windows 8.1).

I'm trying to upgrade the open SSL to verion 1.0.2 so I have TLS 1.2 supported.

I downloaded this file: OpenSSL 1.0.2g upgrade for VC9 Apache 2.2.31 , from here: https://www.apachehaus.com/cgi-bin/download.plx

In the readme file is says to replace the following 6 files:

    /Apache22/bin/abs.exe
    /Apache22/bin/openssl.exe
    /Apache22/bin/libeay32.dll
    /Apache22/bin/ssleay32.dll
    /Apache22/conf/openssl.cnf
    /Apache22/modules/mod_ssl.so

I did just that but apache won't start (I'm getting the "the requested operation has failed!" error).

If I comment out LoadModule ssl_module modules/mod_ssl.so in httpd.conf it will start fine (without OpenSSL of course).
On top of that, I am NOT seeing any error messages in the apache error.log file.

I read a few posts here on the forum and discovered the "httpd -w -e debug" command, run it, and here is the problem:

Cannot load C:/Program Files (x86)/Apache Software Foundation/Apache2.2/modules/mod_ssl.so into server: The specified procedure could not be found.

The mod_ssl.so file IS OBVIOUSLY IN THAT LOCATION, so I'm totally clueless as to how to proceed from here on...

Would appreciate some help

Thanks!
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Apache 2.2.29 crashes when trying to upgrade to OpenSSL 1.0.2g
« Reply #1 on: March 18, 2016, 10:37:42 PM »

Duplicated with ease.

That update is for Apache 2.2.31. Normally this should not matter because 2.2.x is supposed to be binary compatible with 2.2.next and is for the most part, but not today.

So how I fixed this problem, I upgraded the rest of the server to 2.2.31. Copied the /bin and modules folder from the httpd-2.2.31-x86-r3.zip file.

So just grab the 2.2.31-x86-r3 download and copy the /bin and /modules folders. Backup your working 2.2.29 first if you haven't already  :)
Logged

Zeev

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: Apache 2.2.29 crashes when trying to upgrade to OpenSSL 1.0.2g
« Reply #2 on: March 18, 2016, 11:23:14 PM »

Brilliant!
Solved my problem in under a minute.
Thanks Gregg!!
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13