The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Compile mod_spamhaus for more Security  (Read 3600 times)

xerox

  • Newbie
  • *
  • Offline Offline
  • Posts: 8
Compile mod_spamhaus for more Security
« on: April 04, 2014, 09:24:39 PM »

Hello and good "morning"  ;)

I'm all done with my Securing of Apache, but security is not a permanent condition !
Can anyone help to compile the module "mod_spamhaus" (http://sourceforge.net/projects/mod-spamhaus/)
Is it compatible with Apache 2.4.9 ?
I am not a C Programmer, i can only scripts, like PHP, Python ans so one + HTML, CSS, JS, and so one...

Thank you.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Re: Compile mod_spamhaus for more Security
« Reply #1 on: April 06, 2014, 08:45:55 PM »

It's not Windows or 2.4 friendly by any means but a little modification and it compiles at least.

Which are you using, vc9 or 11, x86 or x64? You will be the one testing it ;D
Never mind, I see your using 2.4.9 VC9 x64.

Untested, it loads on my 2.4.9 vc9 x64 Apache.
https://www.apachehaus.net/modules/untested/mod_spamhaus-0.7.1-2.4.x-x64.zip
Logged

xerox

  • Newbie
  • *
  • Offline Offline
  • Posts: 8
Re: Compile mod_spamhaus for more Security
« Reply #2 on: April 13, 2014, 08:59:43 PM »

Thank you for your help !, great job.

Im sorry that i writing so late, but was for business away, and no internet access.
Im testing the module in the new week in detail. The first time looks good !

Thanks !
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13