The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Apache 2.4.25 LibreSSL 2.5.1 VC14  (Read 2539 times)

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 831
Apache 2.4.25 LibreSSL 2.5.1 VC14
« on: February 12, 2017, 09:45:15 PM »

I have built Apache 2.4 with LibreSSL a couple times now to test and feel it's time I finally shared.

I can not guarantee I will be building them ever time a new LibreSSL version comes out because while they support Windows, they do not guarantee every release will build on Windows. Per the LibreSSL website;

Quote
Primary development occurs inside the OpenBSD source tree with the usual care the project is known for.
On a regular basis the code is re-packaged for portable use by other operating systems (Linux, FreeBSD, Windows, etc).

As for 2.5.0, it was the case that not every component would build. So just because a new release comes out don't expect our downloads to be updated in turn. Also, while Libressl is not hard to build, it is much more time consuming so I take my time at getting to them.

For now consider these builds to be experimental.
The are built with;

APR Version1.5.2
APR-Util Version1.5.4
PCRE Version8.40
ZLib Version1.2.10
Lua Version5.1.5
LibXML2 Version2.9.4
NGHTTP2 Version1.19.0
SQLite3 Version3.16.2

You can get your copy from our Download Page.


Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13