The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1] 2 3   Go Down

Author Topic: Mod GeoIP 1.2.8 directive for Apache 2.4.x x64 can't run  (Read 18507 times)

chromerep

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 63
Mod GeoIP 1.2.8 directive for Apache 2.4.x x64 can't run
« on: June 26, 2013, 02:32:31 AM »

I download Mod GeoIP 1.2.8 for Apache 2.4.x x64 from AH.But,it shows can't load mod_geoip.so at conf file.I make a try to download Mod GeoIP 1.2.7 for Apache 2.4.x x64 from AH,it runs well.

Does it something wrong with Mod GeoIP 1.2.8 for Apache 2.4.x x64? ;)
« Last Edit: June 29, 2013, 12:40:49 PM by chromerep »
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #1 on: June 26, 2013, 07:17:59 AM »

Possibly, what version of Windows are you running?

It's not loading on my XP x86, but loads fine on my Vista x86. I realize your talking x64 though. I think I'll put 1.2.7b back on the download page anyway.
Logged

chromerep

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 63
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #2 on: June 26, 2013, 10:31:37 PM »

I run it under win 2008R2 server(apache2.4).And,I find it can't set allowed country code either both 1.2.7 and 1.2.8 via http://dev.maxmind.com/geoip/legacy/mod_geoip2/.Is there any right directive to provide to tuning?
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #3 on: June 26, 2013, 11:31:47 PM »

Code: [Select]
GeoIPEnable On
GeoIPDBFile /path/to/GeoIP.dat

SetEnvIf GEOIP_COUNTRY_CODE US AllowCountry
SetEnvIf GEOIP_COUNTRY_CODE CA AllowCountry
SetEnvIf GEOIP_COUNTRY_CODE MX AllowCountry
# ... place more countries here
<Directory "/path/to/some/website">
# your Options and AllowOverrides and anything else
Require env AllowCountry
</Directory>

I believe the above should work in 2.4

I'm surprised 1.2.8 doesn't load in 2008R2, It should in Vista and up. Do you get a "The specified procedure could not be found." in the error message?
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #4 on: June 27, 2013, 03:43:09 AM »

I have it running on a 32-bit Windows 2008 server.  Made no changes whatsoever to my .conf files when upgrading from 1.2.7b to 1.2.8.

 - S
Logged

chromerep

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 63
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #5 on: June 27, 2013, 06:22:45 AM »

Gregg:

Can you post Block country full directives fro httpd.conf use? :)
The allowed directives works fine.And,I need the block directives too.

Code: [Select]
GeoIPEnable On
GeoIPDBFile /path/to/GeoIP.dat

SetEnvIf GEOIP_COUNTRY_CODE US AllowCountry
SetEnvIf GEOIP_COUNTRY_CODE CA AllowCountry
SetEnvIf GEOIP_COUNTRY_CODE MX AllowCountry
# ... place more countries here
<Directory "/path/to/some/website">
# your Options and AllowOverrides and anything else
Require env AllowCountry
</Directory>
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #6 on: June 27, 2013, 11:54:48 AM »

If I remember correctly, it was

Code: [Select]
SetEnvIf GEOIP_COUNTRY_CODE US BlockCountry
SetEnvIf GEOIP_COUNTRY_CODE CA BlockCountry
SetEnvIf GEOIP_COUNTRY_CODE MX BlockCountry
# ... place more countries here
<Directory "/path/to/some/website">
# your Options and AllowOverrides and anything else
  <RequireAll>
    Require all granted
    Require not env BlockCountry
  </RequireAll>
</Directory>

although I do see this in my config

Code: [Select]
  <RequireAll>   
    Require all granted
    <RequireNone>
      Require env BlockCountry
    </RequireNone>
  </RequireAll>   
Logged

chromerep

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 63
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #7 on: June 27, 2013, 12:21:09 PM »

Thanks.And..
Would yould please to fix mod_geoip1.2.8 for 2008R2 x64 to use?
Logged

DnvrSysEngr

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #8 on: June 27, 2013, 06:32:11 PM »

Gregg:

I can concur that there is an issue with the 64-bit Mod_GeoIP module.  I have a 64-bit Windows8 development box running the 64-bit version of Apache 2.4.4.  I replaced Mod_GeoIP 1.2.7b with 1.2.8 and Apache 2.4.4 would not start.  The moment I reverted back to 1.2.7b, Apache 2.4.4 started.

 - S
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #9 on: June 27, 2013, 07:35:15 PM »

OK, thanks for the reports. Am pulling 1.2.8 now. Look for 1.2.8a in the near future.
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #10 on: June 27, 2013, 09:48:47 PM »

OK, 1.2.8a is available. I hope these work for you. It's impossible to get any kind of debugging data on windows short of installing a full version of Visual C++. So if I cannot duplicate the problem, it's hard to track it down.
Logged

chromerep

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 63
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #11 on: June 28, 2013, 01:26:41 AM »

Mod_geoip1.2.8a works under 2008R2 now. :)

And,what is the directive of allowed ip(such as private ip...or another blockcountry ip..) at blockcountry setting.I try to use "allow from 192.168.0.0/16" directive,but not works.
« Last Edit: June 28, 2013, 02:43:09 AM by chromerep »
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 579
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #12 on: June 28, 2013, 06:12:43 PM »

Allow from is not 2.4 style. Use the require style.

Require ip 192.168
Logged

chromerep

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 63
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #13 on: June 28, 2013, 11:43:20 PM »

It shows "systax error and unknown authz provider" when use "require" directive under apache2.4.4 ::)

So strange?
« Last Edit: June 29, 2013, 02:20:47 AM by chromerep »
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: Mod GeoIP 1.2.8 for Apache 2.4.x x64 can't load
« Reply #14 on: June 29, 2013, 05:05:02 AM »

is mod_authz_host loaded?
Logged
Pages: [1] 2 3   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13