The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: Apache 2.4 not responding to DNS requests but for hostname  (Read 2477 times)

Karthick

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Apache 2.4 not responding to DNS requests but for hostname
« on: September 08, 2016, 02:53:26 PM »

Hi

We are having strange problem on Apache haus in Production environment. Apache is not responding when we hit the URL "https://example.com/test" (getting Page cannot be displayed on IE)but it is responding to url "https://hostname/test".

Apache Server Status page is not logging IP Address of client when we use DNS URL but for URL with "https//hostname/test"

This is happening only every 3 to 4 days after Apache was restarted. No errors in log files. Its not DNS issue because once Apache is restarted all starts working. we have 150 workers thread configured.Not much traffic on the site.

 Apache seems not reading DNS req. but hostname based requests over a period of time. Please help with your suggestion.

Thanks,
Karthick
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 839
Re: Apache 2.4 not responding to DNS requests but for hostname
« Reply #1 on: September 08, 2016, 04:33:28 PM »

There's nothing in the error log about Asynchronous AcceptEx ?

This sounds like that problem.

Find these in httpd.conf (they start at line 470 on our default config), uncomment, save changes  and restart Apache then give it a couple days to see if it happens again.

Code: [Select]
AcceptFilter http none
AcceptFilter https none
This is all I can think of, its happened to me.
Logged

Karthick

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: Apache 2.4 not responding to DNS requests but for hostname
« Reply #2 on: September 08, 2016, 05:10:52 PM »

Thanks for the reply.
Nothing reported on logs. Server status not even logging IP address of client when DNS URL used. Seems not hitting Apache server.

Only entry "AcceptFilter http none" is present and enabled . I will add "AcceptFilter https none" also and will observe for sometime.

Regards,
Karthick
Logged

Karthick

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: Apache 2.4 not responding to DNS requests but for hostname
« Reply #3 on: September 13, 2016, 09:34:44 PM »

Hi ,

I have noticed today that TIME_WAIT status for Apache logged when ran the netstat command.
anything to do with keepalive?
Any ideas?

Thanks,
Karthick
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 839
Re: Apache 2.4 not responding to DNS requests but for hostname
« Reply #4 on: September 13, 2016, 11:11:26 PM »

Anything is possible I guess, but the default, here anyway, on our builds is 5 seconds, that's pretty short. That really sounded like the AcceptFilter problem that happens on most Windows machines. Because mine would not connect to www.domain.com but would answer to the IP or internal hostname until I'd do a restart.
Logged

Karthick

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: Apache 2.4 not responding to DNS requests but for hostname
« Reply #5 on: September 14, 2016, 01:58:45 PM »

we are also facing same problem.
Apache is not responding to https://example.com/test or http://example.com/test but answers to the IP or hostname based URL until I'd do a restart.
default keepalive settings i m using
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13