The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: [1]   Go Down

Author Topic: OK, what's the deal?  (Read 5413 times)

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
OK, what's the deal?
« on: July 10, 2010, 03:14:24 AM »

So I decided I'd get mod_antiloris x64 built and up on the downloads page.
I built it, copied into my Apache 2.2.15 x64 and from the command line typed

httpd

Apache hung at the command line and would not answer.
So for the hell oh it I installed the service, it installed but hung and would not release the command line till I ctrl+c then Esc
Went into services and started Apache, it started and It Works!

Why does it give me hell at the command line is what I want to know.
I figure my 2.3.6 with fcgid will work if ran as a service now too, similar to the crap that happened with 2.2.15x86/php5.3.2x86 in yhe AL post.

I was logged in as admin. Blows my mind! Any ideas on how to get it working at command line for testing? Guess I install the service for both 2.2.15 and 2.3.6 and just start stop from now on ... but prefer to test from command line.
Logged

mario

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 579
Re: OK, what's the deal?
« Reply #1 on: July 10, 2010, 08:06:11 PM »

APR change or in httpd code? Maybe it is useful to compare the code from 2.2 and 2.trunk

Mr. Chainsaw  ;)
Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: OK, what's the deal?
« Reply #2 on: July 12, 2010, 12:19:43 AM »

Heh heh ... Chansaw

I was speaking 2.2.15. I think it's the UAC in 2k8. I think it's why I had problem getting php 5.3.2 vc9 to run with 2.2.15 vc9 on Vista. So, I have to assume Win7 is going to act the same.

However, there is something in 5.3.2 since running with 5.2.13 on Vista works like I were on the XP box.

I brought up 2.3.6 cause it produced the exact problem at command line, even when command line was run as admin in 2.3.6. Only it did not want to run if any php version, any vc used, if php has been configured for mod_fcgid. I'm going to assume at this point if I install the service for 2.3.6 on 2k8 that problem will go away.

This however leads to a security issue. If I cannot run it when service running under a limited user, only as System, then there is a problem. I do not like running Apache not jailed.

Anyway, since I think I know what is going on, I am going to change the instructions in a couple readme files to note this behavior. First however, I am booting up 2k8 now to test my theories.






Logged

Gregg

  • Administrator
  • Member Elite
  • *****
  • Offline Offline
  • Posts: 837
Re: OK, what's the deal?
« Reply #3 on: July 12, 2010, 12:42:29 AM »

That seems to be it, I've got 2.3.6 x64 running PHP with mod_fcgid  on 2k8.
So expect a 2.3.6 x64, mod_antiloris and mod_security download in the next day or two.
Logged
Pages: [1]   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13