The Apache Haus Forum

Advanced search  

News:

Welcome to Apache Haus Distribution Forum

Pages: 1 2 [3] 4 5 ... 10
 21 
 on: April 20, 2021, 07:46:01 AM 
Started by EHCanadian83 - Last post by Gregg
Looks like I'm going to have to rebuild them. I will do them tomorrow, check back in 24 hours. It's near bed time.

 22 
 on: April 19, 2021, 10:33:31 PM 
Started by EHCanadian83 - Last post by EHCanadian83
The VS15 mod_maxmind x86 and x64 are showing up but no zip.

 23 
 on: April 13, 2021, 02:34:16 AM 
Started by rr908 - Last post by ernests870
This was a great news and update who visited here you did well a great job.

 24 
 on: April 07, 2021, 05:09:03 AM 
Started by timo.m - Last post by timo.m
Downloaded, thanks.

 25 
 on: April 06, 2021, 11:34:01 PM 
Started by timo.m - Last post by Gregg
Done and on the download page.

 26 
 on: April 06, 2021, 06:45:22 PM 
Started by timo.m - Last post by Gregg
Now that's embarrassing, not just x64 but x86 is also missing the module  :-[

I have an appointment to be at soon but I will have a new download ready later today (1.1.0.132-2) and will post an update here when it's ready.

 27 
 on: April 06, 2021, 04:10:12 PM 
Started by timo.m - Last post by timo.m
Hello.

I downloaded Mod MaxmindDB for Apache 2.4.x x64 VS16 version (mod_maxminddb-1.1.0.132-x64-vs16.zip), but I couldn't install it because it lacks the mod_maxminddb.so file.

In VC15 versions that file is included.

Could you recreate VS16 zip-files?

Kind regards, Timo

 28 
 on: March 27, 2021, 08:49:45 AM 
Started by Gregg - Last post by mario
Thank you for the build

 29 
 on: March 26, 2021, 09:12:05 PM 
Started by Gregg - Last post by Gregg
I must say I like it when OpenSSL & LibreSSL release within days of each other, makes it easier for updates, until something else goes wrong.

So with a little fanfare, we give you updates. Updating to OpenSSL is a must, there is a proof of concept that these vulnerabilities can lead to a denial-of-service. LibreSSL is probably a good idea to get updated as well with a use after free bug fixed that can be triggered by remote.

 Changes between OpenSSL 1.1.1j and 1.1.1k [25 Mar 2021]

  *) Fixed a problem with verifying a certificate chain when using the
     X509_V_FLAG_X509_STRICT flag. This flag enables additional security checks
     of the certificates present in a certificate chain. It is not set by
     default.

     Starting from OpenSSL version 1.1.1h a check to disallow certificates in
     the chain that have explicitly encoded elliptic curve parameters was added
     as an additional strict check.

     An error in the implementation of this check meant that the result of a
     previous check to confirm that certificates in the chain are valid CA
     certificates was overwritten. This effectively bypasses the check
     that non-CA certificates must not be able to issue other certificates.

     If a "purpose" has been configured then there is a subsequent opportunity
     for checks that the certificate is a valid CA.  All of the named "purpose"
     values implemented in libcrypto perform this check.  Therefore, where
     a purpose is set the certificate chain will still be rejected even when the
     strict flag has been used. A purpose is set by default in libssl client and
     server certificate verification routines, but it can be overridden or
     removed by an application.

     In order to be affected, an application must explicitly set the
     X509_V_FLAG_X509_STRICT verification flag and either not set a purpose
     for the certificate verification or, in the case of TLS client or server
     applications, override the default purpose.
     (CVE-2021-3450)
     [Tomáš Mráz]
     Severity: High

  *) Fixed an issue where an OpenSSL TLS server may crash if sent a maliciously
     crafted renegotiation ClientHello message from a client. If a TLSv1.2
     renegotiation ClientHello omits the signature_algorithms extension (where
     it was present in the initial ClientHello), but includes a
     signature_algorithms_cert extension then a NULL pointer dereference will
     result, leading to a crash and a denial of service attack.

     A server is only vulnerable if it has TLSv1.2 and renegotiation enabled
     (which is the default configuration). OpenSSL TLS clients are not impacted
     by this issue.
     (CVE-2021-3449)
     [Peter Kästle and Samuel Sapalski]
     Severity: High

   Changes between LibreSSL 3.2.4 and 3.2.5 [17 Mar 2021]

  *) A TLS client using session resumption may cause a use-after-free.


As always, you can get your copy of the updated Apache HTTP Server from our download page.


 30 
 on: March 22, 2021, 05:49:24 AM 
Started by shishir - Last post by preeti123
That sort of error i was facing Long back and i didn't found out any solutions  :-\

Pages: 1 2 [3] 4 5 ... 10